A8 Parts Forum  

Go Back   A8 Parts Forum > A8 D2 > D2 - Transmission

D2 - Transmission Gearboxes, diffs, drive shafts.

Reply
 
Thread Tools Display Modes
  #1  
Old 21st October 2020, 05:03 PM
scottmgibb scottmgibb is offline
Member
 
Join Date: May 2017
Location: Aberdeenshire
Posts: 40
Default Tiptronic engagement issue

Hi there,

I am having a problem diagnosing an issue with the automatic gearbox on my 2002 S8 D2. I have had the car for around 3½ years, and have lived with this issue throughout. The problem is that the gearbox will not (generally) allow the engagement of Tiptronic mode. The scenario is this:

Gear display on dashboard goes into ‘red’ error mode as soon as you start the car and stays that way permanently.

Car drives perfectly normal in D, R & S modes, but moving the gear leaver into Tiptronic position does nothing.

However, if you are very quick to move the leaver into the Tiptronic position when starting the car then it does go into manual mode, and the gear display on dashboard shows the normal 1-2-3-4-5. It works perfectly in manual mode (both using the leaver or buttons on steering wheel).

Putting it back into ‘D’ mode does nothing (you can move it back and forth between D and Tiptronic modes and it just stays in Tiptronic), but if you put it in R, N or S mode it will revert back to the dashboard ‘red’ error mode, and then will then not go back into Tiptronic mode (though D, R & S modes continues to work perfectly; D works again once you have been in one of the other modes).

The VAG-COM error is shown is:

18152 – Tiptronic Recognition Switch (F189): Short to Ground P1744 – 35-00 - -

If you try clearing the code it just come back up straight away.

I have tried swapping over the F189 switch for another one out of a used gear lever from Prestige, but this gives the same results (with the code clearing/reappearing being the same too). Of course this used switch could have the same fault, but it was in theory tested before being sold.

The fact that you can engage (albeit in a very specific way) the Tiptronic mode and manually change the gears would seem to suggest that it is not the F189 switch that is at fault (though the fact that is does not switch out of Tiptronic mode when moving back to D is odd).

My other thought is the F125 switch, but the fact that both automatic and manual modes work fine (albeit, again, in a very specific way) would seem to suggest this is not the issue either.

I have read many a post on many a forum, but have not seen anything that seems to address this specific issue.

Does anybody have any ideas where the problem might lie, or think it could still be one of these switches that is causing the issue?

Thanks! Scott
__________________
Audi S8 D2 2002
Reply With Quote
  #2  
Old 21st October 2020, 05:11 PM
HPsauce HPsauce is offline
Senior Member
 
Join Date: Sep 2011
Location: Chilterns, almost over HS2!
Posts: 8,061
Default

My first thought is a wiring issue somewhere, given that you've swapped the switch but the error/behaviour are the same.

Someone better than me at reading wiring diagrams can probably say what the wires are and what route they may take to where.

Do you have tiptronic buttons on your steering wheel too?
__________________
2003 D2 FL S8. Irish Green Pearl/Beige. Solar sunroof, auto-dim mirrors, electric rear seat functions, ski hatch retrofit; extended leather. Aftermarket DVB-T, reversing camera and full XCarlink (Bluetooth etc.).
2016 Volvo V40 T5 Cross Country (4WD) with ALL the toys including adaptive cruise etc. etc. Osmium Grey with Blonde/Charcoal leather interior. Polestar performance "optimisation". (A much rarer model than a D2 S8 by the way!)
Finally: gone, but not forgotten.....
1998 D2 PF S8. AgateGrey/Platinum. Every option (I think) except electric rear seats, tiptronic steering wheel, ski hatch, towbar & dimming door mirrors.
e.g. Cruise control, NavPlus/TV, Bose, GSM, Xenons, Solar roof, Parking sensors, Alcantara/leather everywhere of course. (internal dimming mirror added later)
1998 (very early) Ford Focus 1.8 Zetec; ABS/TCS, Heated screen/mirrors, Aircon, Auto-dim mirror, Leather, Trip computer, Cruise control, OEM Ford SatNav with CD changer.
Reply With Quote
  #3  
Old 21st October 2020, 05:42 PM
scottmgibb scottmgibb is offline
Member
 
Join Date: May 2017
Location: Aberdeenshire
Posts: 40
Default

Thanks for the quick responce!

I have switches on the wheel, but not the paddles, and they work fine when you get the car into manual mode.

Do you know if there is a control unit for these switches? I wonder if they could be disabled to see if that is the issue...

It is so weird that everything can work, but just generally does not. Something seems to be sending an error signal about the Tiptronic system when the car is started, but if you are quick enough you can bypass it and then everthing seems to work...!
__________________
Audi S8 D2 2002
Reply With Quote
  #4  
Old 21st October 2020, 05:57 PM
MikkiJayne MikkiJayne is offline
Senior Member
 
Join Date: Jan 2012
Location: Devon
Posts: 4,616
Default

Interesting fault. This one will require some pondering...

In the meantime, this is the F189 wiring to the TCU:



The bit in red is the tip engagement switch. The two to the left are up / down. Assuming the steering wheel is the 3-spoke with tiptronic and not the multi-function 4-spoke then the two buttons are just wired directly in to the F189 wiring.

Two things I would try - swap the TCU (although thats easy as I have a box of them), and unplug the shifter with the black square-ish plug to the front right of it, and see how it responds.

Happy to lend a TCU for diagnostic purposes, for a small deposit and postage costs

Thinking cap on...
Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	414
Size:	143.6 KB
ID:	24251  

Last edited by MikkiJayne; 21st October 2020 at 05:59 PM.
Reply With Quote
  #5  
Old 21st October 2020, 06:53 PM
HPsauce HPsauce is offline
Senior Member
 
Join Date: Sep 2011
Location: Chilterns, almost over HS2!
Posts: 8,061
Default

Quote:
Originally Posted by scottmgibb View Post
I have switches on the wheel, but not the paddles, and they work fine when you get the car into manual mode.
But don't the steering wheel buttons work anyway without moving the stick out of D? I'm sure mine do and it's a very similar vintage. Have you tried that?
__________________
2003 D2 FL S8. Irish Green Pearl/Beige. Solar sunroof, auto-dim mirrors, electric rear seat functions, ski hatch retrofit; extended leather. Aftermarket DVB-T, reversing camera and full XCarlink (Bluetooth etc.).
2016 Volvo V40 T5 Cross Country (4WD) with ALL the toys including adaptive cruise etc. etc. Osmium Grey with Blonde/Charcoal leather interior. Polestar performance "optimisation". (A much rarer model than a D2 S8 by the way!)
Finally: gone, but not forgotten.....
1998 D2 PF S8. AgateGrey/Platinum. Every option (I think) except electric rear seats, tiptronic steering wheel, ski hatch, towbar & dimming door mirrors.
e.g. Cruise control, NavPlus/TV, Bose, GSM, Xenons, Solar roof, Parking sensors, Alcantara/leather everywhere of course. (internal dimming mirror added later)
1998 (very early) Ford Focus 1.8 Zetec; ABS/TCS, Heated screen/mirrors, Aircon, Auto-dim mirror, Leather, Trip computer, Cruise control, OEM Ford SatNav with CD changer.

Last edited by HPsauce; 21st October 2020 at 08:09 PM.
Reply With Quote
  #6  
Old 21st October 2020, 07:01 PM
MikkiJayne MikkiJayne is offline
Senior Member
 
Join Date: Jan 2012
Location: Devon
Posts: 4,616
Default

Tip buttons in D are a TCU coding thing and definitely should work on an 02 S8. Assuming the stick is in D (red-circled switch) then the TCU will still respond to the tip signals which it knows are coming from the steering wheel, thus it goes back to D on its own after a bit.

There is a diode in the circuit from the tip-engage switch so that the TCU doesn't see the power to the two lights in the shifter which the engage switch also operates. I wonder if a fault on the lights would cause the TCU to see a stuck ground on the switch...? Still pondering.
Reply With Quote
  #7  
Old 21st October 2020, 08:04 PM
HPsauce HPsauce is offline
Senior Member
 
Join Date: Sep 2011
Location: Chilterns, almost over HS2!
Posts: 8,061
Default

So it would possibly be helpful with the diagnosis to know if the steering wheel tip buttons work when in D?
And yes, it does revert to D after maybe 30 seconds or so.
Furthermore, when I saw that diagram the diode stuck out like a sore thumb.....
__________________
2003 D2 FL S8. Irish Green Pearl/Beige. Solar sunroof, auto-dim mirrors, electric rear seat functions, ski hatch retrofit; extended leather. Aftermarket DVB-T, reversing camera and full XCarlink (Bluetooth etc.).
2016 Volvo V40 T5 Cross Country (4WD) with ALL the toys including adaptive cruise etc. etc. Osmium Grey with Blonde/Charcoal leather interior. Polestar performance "optimisation". (A much rarer model than a D2 S8 by the way!)
Finally: gone, but not forgotten.....
1998 D2 PF S8. AgateGrey/Platinum. Every option (I think) except electric rear seats, tiptronic steering wheel, ski hatch, towbar & dimming door mirrors.
e.g. Cruise control, NavPlus/TV, Bose, GSM, Xenons, Solar roof, Parking sensors, Alcantara/leather everywhere of course. (internal dimming mirror added later)
1998 (very early) Ford Focus 1.8 Zetec; ABS/TCS, Heated screen/mirrors, Aircon, Auto-dim mirror, Leather, Trip computer, Cruise control, OEM Ford SatNav with CD changer.

Last edited by HPsauce; 21st October 2020 at 08:06 PM.
Reply With Quote
  #8  
Old 21st October 2020, 08:12 PM
scottmgibb scottmgibb is offline
Member
 
Join Date: May 2017
Location: Aberdeenshire
Posts: 40
Default

Thanks for the great replies!

The steering wheel is the 3-spoke version – no additional buttons other than the tiptronic.

I was not aware that the buttons should work in D (that sounds quite useful!). Just been out to test it, and they do not work on mine currently (when in D).

MikkiJayne – I would take you up on that offer. Do we arrange that via PM? Just send me the details if so.

And when you say “unplug the shifter with the black square-ish plug to the front right of it”, do you mean the plug at the side of the shifter mechanism that attaches the F189 switch?

Thanks again for all your help! Scott
__________________
Audi S8 D2 2002
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.