A8 Parts Forum

A8 Parts Forum (http://forum.a8parts.co.uk/index.php)
-   D2 - Transmission (http://forum.a8parts.co.uk/forumdisplay.php?f=27)
-   -   Tiptronic engagement issue (http://forum.a8parts.co.uk/showthread.php?t=15929)

scottmgibb 21st October 2020 05:03 PM

Tiptronic engagement issue
 
Hi there,

I am having a problem diagnosing an issue with the automatic gearbox on my 2002 S8 D2. I have had the car for around 3½ years, and have lived with this issue throughout. The problem is that the gearbox will not (generally) allow the engagement of Tiptronic mode. The scenario is this:

Gear display on dashboard goes into ‘red’ error mode as soon as you start the car and stays that way permanently.

Car drives perfectly normal in D, R & S modes, but moving the gear leaver into Tiptronic position does nothing.

However, if you are very quick to move the leaver into the Tiptronic position when starting the car then it does go into manual mode, and the gear display on dashboard shows the normal 1-2-3-4-5. It works perfectly in manual mode (both using the leaver or buttons on steering wheel).

Putting it back into ‘D’ mode does nothing (you can move it back and forth between D and Tiptronic modes and it just stays in Tiptronic), but if you put it in R, N or S mode it will revert back to the dashboard ‘red’ error mode, and then will then not go back into Tiptronic mode (though D, R & S modes continues to work perfectly; D works again once you have been in one of the other modes).

The VAG-COM error is shown is:

18152 – Tiptronic Recognition Switch (F189): Short to Ground P1744 – 35-00 - -

If you try clearing the code it just come back up straight away.

I have tried swapping over the F189 switch for another one out of a used gear lever from Prestige, but this gives the same results (with the code clearing/reappearing being the same too). Of course this used switch could have the same fault, but it was in theory tested before being sold.

The fact that you can engage (albeit in a very specific way) the Tiptronic mode and manually change the gears would seem to suggest that it is not the F189 switch that is at fault (though the fact that is does not switch out of Tiptronic mode when moving back to D is odd).

My other thought is the F125 switch, but the fact that both automatic and manual modes work fine (albeit, again, in a very specific way) would seem to suggest this is not the issue either.

I have read many a post on many a forum, but have not seen anything that seems to address this specific issue.

Does anybody have any ideas where the problem might lie, or think it could still be one of these switches that is causing the issue?

Thanks! Scott

HPsauce 21st October 2020 05:11 PM

My first thought is a wiring issue somewhere, given that you've swapped the switch but the error/behaviour are the same.

Someone better than me at reading wiring diagrams can probably say what the wires are and what route they may take to where.

Do you have tiptronic buttons on your steering wheel too?

scottmgibb 21st October 2020 05:42 PM

Thanks for the quick responce!

I have switches on the wheel, but not the paddles, and they work fine when you get the car into manual mode.

Do you know if there is a control unit for these switches? I wonder if they could be disabled to see if that is the issue...

It is so weird that everything can work, but just generally does not. Something seems to be sending an error signal about the Tiptronic system when the car is started, but if you are quick enough you can bypass it and then everthing seems to work...!

MikkiJayne 21st October 2020 05:57 PM

1 Attachment(s)
Interesting fault. This one will require some pondering...

In the meantime, this is the F189 wiring to the TCU:

http://forum.a8parts.co.uk/attachmen...1&d=1603302633

The bit in red is the tip engagement switch. The two to the left are up / down. Assuming the steering wheel is the 3-spoke with tiptronic and not the multi-function 4-spoke then the two buttons are just wired directly in to the F189 wiring.

Two things I would try - swap the TCU (although thats easy as I have a box of them), and unplug the shifter with the black square-ish plug to the front right of it, and see how it responds.

Happy to lend a TCU for diagnostic purposes, for a small deposit and postage costs +++

Thinking cap on...

HPsauce 21st October 2020 06:53 PM

Quote:

Originally Posted by scottmgibb (Post 160374)
I have switches on the wheel, but not the paddles, and they work fine when you get the car into manual mode.

But don't the steering wheel buttons work anyway without moving the stick out of D? I'm sure mine do and it's a very similar vintage. Have you tried that?

MikkiJayne 21st October 2020 07:01 PM

Tip buttons in D are a TCU coding thing and definitely should work on an 02 S8. Assuming the stick is in D (red-circled switch) then the TCU will still respond to the tip signals which it knows are coming from the steering wheel, thus it goes back to D on its own after a bit.

There is a diode in the circuit from the tip-engage switch so that the TCU doesn't see the power to the two lights in the shifter which the engage switch also operates. I wonder if a fault on the lights would cause the TCU to see a stuck ground on the switch...? Still pondering.

HPsauce 21st October 2020 08:04 PM

So it would possibly be helpful with the diagnosis to know if the steering wheel tip buttons work when in D?
And yes, it does revert to D after maybe 30 seconds or so.
Furthermore, when I saw that diagram the diode stuck out like a sore thumb.....

scottmgibb 21st October 2020 08:12 PM

Thanks for the great replies!

The steering wheel is the 3-spoke version – no additional buttons other than the tiptronic.

I was not aware that the buttons should work in D (that sounds quite useful!). Just been out to test it, and they do not work on mine currently (when in D).

MikkiJayne – I would take you up on that offer. Do we arrange that via PM? Just send me the details if so.

And when you say “unplug the shifter with the black square-ish plug to the front right of it”, do you mean the plug at the side of the shifter mechanism that attaches the F189 switch?

Thanks again for all your help! Scott

HPsauce 21st October 2020 08:18 PM

I wonder where the diode is and if it's possible to disconnect it then try the tip buttons (and shifter tip movements) in D?
It must be near the shifter as it's between T10g and T5g which are both in that area.

Looking at the wiring diagram a bit more there's probably a small/short loom between T5n T5g and T10g (and maybe also T2af) all in that area and the diode may be incorporated into that.
If that loom can be separated out easily A8parts may be able to supply a replacement.

scottmgibb 21st October 2020 08:43 PM

1 Attachment(s)
Would the diode be in the wiring item marked 26 on the attached image (borrowed from another post somewhere identifying the tiptronic select switch, hence the red arrow)?


All times are GMT. The time now is 01:21 PM.

Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.